Back
Downtime

Service outage
Started 29 Mar at 05:49pm EDT, resolved 29 Mar at 06:10pm EDT.
Web application
Resolved
A service provider experienced an outage, causing an outage of our own platform for about thirty-five minutes starting around 5:20pm ET. They've fixed the problem, and we are back online. We apologize for any inconvenience.
Posted 29 Mar at 06:10pm EDT.

Created
We’re experiencing a service outage with our application. Our team is currently working to restore the service. We apologize for any inconvenience. Next update in 30 minutes on our status page.
Posted 29 Mar at 05:49pm EDT.